summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRadek Novacek <rnovacek@redhat.com>2012-07-23 13:41:47 +0200
committerRadek Novacek <rnovacek@redhat.com>2012-07-23 14:35:13 +0200
commitce3f2520c5046c7b7703742dd5c7481b5f98c52e (patch)
tree4e6ac6dbcb4b06f6d0ad02630a086ab263c1071b /CMakeLists.txt
parent3f906be3f651313c1b8709732ea0bdebba296784 (diff)
downloadopenlmi-providers-ce3f2520c5046c7b7703742dd5c7481b5f98c52e.tar.gz
openlmi-providers-ce3f2520c5046c7b7703742dd5c7481b5f98c52e.tar.xz
openlmi-providers-ce3f2520c5046c7b7703742dd5c7481b5f98c52e.zip
Restructure Power provider
* get rid of src/ subdirectory in power/ * cleanup CMake * use konkretcmpi_generate macro
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 36df36f..76816f2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,4 +21,7 @@ include(CuraMacros)
find_package(CMPI REQUIRED)
find_package(KonkretCMPI REQUIRED)
+find_package(PkgConfig)
+pkg_check_modules(GLIB REQUIRED glib-2.0)
+
add_subdirectory(src)