summaryrefslogtreecommitdiffstats
path: root/utils/rquotad/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'utils/rquotad/Makefile.am')
-rw-r--r--utils/rquotad/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/utils/rquotad/Makefile.am b/utils/rquotad/Makefile.am
index dcc15ac..4bc036f 100644
--- a/utils/rquotad/Makefile.am
+++ b/utils/rquotad/Makefile.am
@@ -1,6 +1,5 @@
## Process this file with automake to produce Makefile.in
-RPCGEN = $(top_builddir)/tools/rpcgen/rpcgen
GENFILES_XDR = rquota_xdr.c
GENFILES_H = rquota.h
@@ -27,9 +26,13 @@ rquotad_CPPFLAGS = $(AM_CPPFLAGS) $(CPPFLAGS) \
MAINTAINERCLEANFILES = Makefile.in
-
+if CONFIG_RPCGEN
+RPCGEN = $(top_builddir)/tools/rpcgen/rpcgen
$(RPCGEN):
make -C $(top_srcdir)/tools/rpcgen all
+else
+RPCGEN = @RPCGEN_PATH@
+endif
$(GENFILES_XDR): %_xdr.c: %.x $(RPCGEN)
test -f $@ && rm -rf $@ || true