summaryrefslogtreecommitdiffstats
path: root/utils/rquotad/Makefile.am
diff options
context:
space:
mode:
authorNeil Brown <neilb@suse.de>2007-03-20 11:15:29 +1100
committerNeil Brown <neilb@suse.de>2007-03-20 11:15:29 +1100
commit453ac684258684e0e8413f4d9ef9822e753d9dbb (patch)
tree1ea32446cb7bdf042bbe888d06c0486fb86d99a3 /utils/rquotad/Makefile.am
parent390e67de5d9fe919d1894359536f0c5527fa2331 (diff)
downloadnfs-utils-453ac684258684e0e8413f4d9ef9822e753d9dbb.tar.gz
nfs-utils-453ac684258684e0e8413f4d9ef9822e753d9dbb.tar.xz
nfs-utils-453ac684258684e0e8413f4d9ef9822e753d9dbb.zip
Add --with-rpcgen= for configure so that the system rpcgen can be used.
Ultimately it makes sense to remove remove rpcgen from the nfs-utils release as it is already in the glibc release. With this patch you can use the system rpcgen to make sure it works. It is not default yet, but it might be in a future release.
Diffstat (limited to 'utils/rquotad/Makefile.am')
-rw-r--r--utils/rquotad/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/utils/rquotad/Makefile.am b/utils/rquotad/Makefile.am
index dcc15ac..4bc036f 100644
--- a/utils/rquotad/Makefile.am
+++ b/utils/rquotad/Makefile.am
@@ -1,6 +1,5 @@
## Process this file with automake to produce Makefile.in
-RPCGEN = $(top_builddir)/tools/rpcgen/rpcgen
GENFILES_XDR = rquota_xdr.c
GENFILES_H = rquota.h
@@ -27,9 +26,13 @@ rquotad_CPPFLAGS = $(AM_CPPFLAGS) $(CPPFLAGS) \
MAINTAINERCLEANFILES = Makefile.in
-
+if CONFIG_RPCGEN
+RPCGEN = $(top_builddir)/tools/rpcgen/rpcgen
$(RPCGEN):
make -C $(top_srcdir)/tools/rpcgen all
+else
+RPCGEN = @RPCGEN_PATH@
+endif
$(GENFILES_XDR): %_xdr.c: %.x $(RPCGEN)
test -f $@ && rm -rf $@ || true