summaryrefslogtreecommitdiffstats
path: root/utils/mount/Makefile.am
diff options
context:
space:
mode:
authorChuck Lever <chuck.lever@oracle.com>2007-09-28 16:36:35 -0400
committerNeil Brown <neilb@suse.de>2007-09-29 07:58:57 +1000
commit2ab6ed792a773751d1f5d60d13a06161559c0e54 (patch)
treebc35f4978046e6dfcaadc3379624e1d71a7b6940 /utils/mount/Makefile.am
parentaf5939d15a41b337cc499a04fe4001a5cd51fdce (diff)
downloadnfs-utils-2ab6ed792a773751d1f5d60d13a06161559c0e54.tar.gz
nfs-utils-2ab6ed792a773751d1f5d60d13a06161559c0e54.tar.xz
nfs-utils-2ab6ed792a773751d1f5d60d13a06161559c0e54.zip
text-based mount.nfs: parse option strings into lists
Adapt a parsing trick used by Python. Parse mount option strings into an abstract data type so we don't have to copy and/or tokenize the whole option string multiple times while trying to manipulate the mount options. Then, just before calling the mount(2) system call, convert the object back into a C string. One major advantage of this approach is that we can copy the final version of the mount options into /etc/mtab when we're done, instead of copying in the original mount options that the user specified. Any fallback from NFS v3 to NFS v2 or TCP to UDP that was done by mount.nfs will be reflected in /etc/mtab. This patch adds methods for creating and manipulating mount option data objects. Signed-off-by: Chuck Lever <chuck.lever@oracle.com> Signed-off-by: Neil Brown <neilb@suse.de>
Diffstat (limited to 'utils/mount/Makefile.am')
-rw-r--r--utils/mount/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/utils/mount/Makefile.am b/utils/mount/Makefile.am
index cfee756..27a01de 100644
--- a/utils/mount/Makefile.am
+++ b/utils/mount/Makefile.am
@@ -9,10 +9,10 @@ man5_MANS = nfs.man
sbin_PROGRAMS = mount.nfs
EXTRA_DIST = nfsmount.x $(man8_MANS) $(man5_MANS)
-mount_nfs_SOURCES = mount.c error.c network.c fstab.c token.c \
+mount_nfs_SOURCES = mount.c error.c network.c fstab.c token.c parse_opt.c \
nfsmount.c nfs4mount.c stropts.c\
nfsumount.c \
- mount_constants.h error.h network.h fstab.h token.h \
+ mount_constants.h error.h network.h fstab.h token.h parse_opt.h \
nfs4_mount.h nfs_mount4.h stropts.h
mount_nfs_LDADD = ../../support/nfs/libnfs.a \