summaryrefslogtreecommitdiffstats
path: root/utils/mount/Makefile.am
diff options
context:
space:
mode:
authorChuck Lever <chuck.lever@oracle.com>2007-09-28 16:36:30 -0400
committerNeil Brown <neilb@suse.de>2007-09-29 07:58:56 +1000
commitaf5939d15a41b337cc499a04fe4001a5cd51fdce (patch)
treed051dd854e4de351288d1d9f6fe752b1509ac68a /utils/mount/Makefile.am
parent7a042b78ba064a36d1c7de797d2af796212fca2e (diff)
downloadnfs-utils-af5939d15a41b337cc499a04fe4001a5cd51fdce.tar.gz
nfs-utils-af5939d15a41b337cc499a04fe4001a5cd51fdce.tar.xz
nfs-utils-af5939d15a41b337cc499a04fe4001a5cd51fdce.zip
mount.nfs: add new string tokenizer facility
To quote the strtok(3) man page: "Avoid using these functions." OK. We've created our own. The main reason for this is that strtok(3) doesn't handle quoted delimiters at all. We need to handle this: context="foo,bar" where 'context' is a single mount option that sets a token string that possibly uses the same delimiter that the mount command uses to separate options (that is, a comma). Signed-off-by: Chuck Lever <chuck.lever@oracle.com> Signed-off-by: Neil Brown <neilb@suse.de>
Diffstat (limited to 'utils/mount/Makefile.am')
-rw-r--r--utils/mount/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/utils/mount/Makefile.am b/utils/mount/Makefile.am
index 23e7ae9..cfee756 100644
--- a/utils/mount/Makefile.am
+++ b/utils/mount/Makefile.am
@@ -9,10 +9,10 @@ man5_MANS = nfs.man
sbin_PROGRAMS = mount.nfs
EXTRA_DIST = nfsmount.x $(man8_MANS) $(man5_MANS)
-mount_nfs_SOURCES = mount.c error.c network.c fstab.c \
+mount_nfs_SOURCES = mount.c error.c network.c fstab.c token.c \
nfsmount.c nfs4mount.c stropts.c\
nfsumount.c \
- mount_constants.h error.h network.h fstab.h \
+ mount_constants.h error.h network.h fstab.h token.h \
nfs4_mount.h nfs_mount4.h stropts.h
mount_nfs_LDADD = ../../support/nfs/libnfs.a \