summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 21 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a8ca3929..9246541d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -194,6 +194,25 @@ fi
AM_CONDITIONAL(ENABLE_GTK_DOC, test x$enable_gtk_doc = xyes)
+
+dnl ==========================================================================
+dnl Test suite (requires check)
+dnl ==========================================================================
+AC_ARG_ENABLE(tests,
+[ --enable-tests build the test suite (default)],
+[case "${enableval}" in
+ yes) tests_val=true;;
+ no) tests_val=false;;
+esac], tests_val=true)
+
+if $tests_val ; then
+ AM_PATH_CHECK
+fi
+
+AM_CONDITIONAL(WITH_TESTS, $tests_val)
+
+
+
dnl ==========================================================================
dnl Where do we want to install docs
dnl ==========================================================================
@@ -312,6 +331,7 @@ python/protocols/Makefile
python/protocols/elements/Makefile
python/tests/Makefile
python/xml/Makefile
+tests/Makefile
win32/Makefile
win32/nsis/Makefile
]
@@ -330,4 +350,4 @@ Configuration:
Build Python binding: ${enable_python}
Build C API reference: ${enable_gtk_doc}
-" \ No newline at end of file
+"