summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorFrederic Peters <fpeters@entrouvert.com>2004-07-24 18:00:16 +0000
committerFrederic Peters <fpeters@entrouvert.com>2004-07-24 18:00:16 +0000
commit1893900d097aac4bafb393cc0e747478499f3a2d (patch)
treeb99b59b1a1f05b8ac7ee889bd3994ab555b1294b /configure.ac
parenteda0f459be1c72ef210b4318eaae6efa06003035 (diff)
downloadlasso-1893900d097aac4bafb393cc0e747478499f3a2d.tar.gz
lasso-1893900d097aac4bafb393cc0e747478499f3a2d.tar.xz
lasso-1893900d097aac4bafb393cc0e747478499f3a2d.zip
using check <http://check.sourceforge.net/> for the test suite
(--enable-tests=no if you don't want them)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 21 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a8ca3929..9246541d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -194,6 +194,25 @@ fi
AM_CONDITIONAL(ENABLE_GTK_DOC, test x$enable_gtk_doc = xyes)
+
+dnl ==========================================================================
+dnl Test suite (requires check)
+dnl ==========================================================================
+AC_ARG_ENABLE(tests,
+[ --enable-tests build the test suite (default)],
+[case "${enableval}" in
+ yes) tests_val=true;;
+ no) tests_val=false;;
+esac], tests_val=true)
+
+if $tests_val ; then
+ AM_PATH_CHECK
+fi
+
+AM_CONDITIONAL(WITH_TESTS, $tests_val)
+
+
+
dnl ==========================================================================
dnl Where do we want to install docs
dnl ==========================================================================
@@ -312,6 +331,7 @@ python/protocols/Makefile
python/protocols/elements/Makefile
python/tests/Makefile
python/xml/Makefile
+tests/Makefile
win32/Makefile
win32/nsis/Makefile
]
@@ -330,4 +350,4 @@ Configuration:
Build Python binding: ${enable_python}
Build C API reference: ${enable_gtk_doc}
-" \ No newline at end of file
+"