summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPetr Spacek <pspacek@redhat.com>2016-10-14 12:08:45 +0200
committerDavid Kupka <dkupka@redhat.com>2016-10-24 13:30:12 +0200
commitb12da59a6cde3580f97e4ceb7303bc85857faf4d (patch)
tree9d06eea17eec400126f9d480149e151b462d8f01 /configure.ac
parentfd3176a72951a2baece36620341991feb94b230a (diff)
downloadfreeipa-b12da59a6cde3580f97e4ceb7303bc85857faf4d.tar.gz
freeipa-b12da59a6cde3580f97e4ceb7303bc85857faf4d.tar.xz
freeipa-b12da59a6cde3580f97e4ceb7303bc85857faf4d.zip
Build: modernize CURL library detection
Use package config instead of checking headers. Package config is faster because it does not invoke compiler and guarantees proper linking flags because these are provided by package maintainer instead of hardcoded into build system. https://fedorahosted.org/freeipa/ticket/6418 Reviewed-By: Lukas Slebodnik <lslebodn@redhat.com> Reviewed-By: Stanislav Laznicka <slaznick@redhat.com> Reviewed-By: Christian Heimes <cheimes@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 1 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index aa0178383..0884d0239 100644
--- a/configure.ac
+++ b/configure.ac
@@ -219,14 +219,7 @@ PKG_CHECK_MODULES([SASL], [libsasl2])
dnl ---------------------------------------------------------------------------
dnl - Check for CURL
dnl ---------------------------------------------------------------------------
-
-CURL_LIBS=
-AC_CHECK_HEADER(curl/curl.h, [], [AC_MSG_ERROR([curl/curl.h not found])])
-AC_CHECK_LIB(curl, curl_easy_init, [CURL_LIBS="-lcurl"])
-if test "x$CURL_LIBS" = "x" ; then
- AC_MSG_ERROR([curl not found])
-fi
-AC_SUBST(CURL_LIBS)
+PKG_CHECK_MODULES([CURL], [libcurl])
dnl ---------------------------------------------------------------------------
dnl - Check for XMLRPC-C