summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPetr Spacek <pspacek@redhat.com>2016-10-14 12:08:30 +0200
committerDavid Kupka <dkupka@redhat.com>2016-10-24 13:30:12 +0200
commitfd3176a72951a2baece36620341991feb94b230a (patch)
treed1fe6382279c4969a447aa815b3c18bf731df0c2 /configure.ac
parent1f1648691de6687e748c5b8267f43cf196bd7cc9 (diff)
downloadfreeipa-fd3176a72951a2baece36620341991feb94b230a.tar.gz
freeipa-fd3176a72951a2baece36620341991feb94b230a.tar.xz
freeipa-fd3176a72951a2baece36620341991feb94b230a.zip
Build: modernize SASL library detection
Use package config instead of checking headers. Package config is faster because it does not invoke compiler and guarantees proper linking flags because these are provided by package maintainer instead of hardcoded into build system. https://fedorahosted.org/freeipa/ticket/6418 Reviewed-By: Lukas Slebodnik <lslebodn@redhat.com> Reviewed-By: Stanislav Laznicka <slaznick@redhat.com> Reviewed-By: Christian Heimes <cheimes@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 1 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 217f81536..aa0178383 100644
--- a/configure.ac
+++ b/configure.ac
@@ -214,11 +214,7 @@ PKG_CHECK_MODULES([POPT], [popt])
dnl ---------------------------------------------------------------------------
dnl - Check for SASL
dnl ---------------------------------------------------------------------------
-
-SASL_LIBS=
-AC_CHECK_HEADER(sasl/sasl.h, [], [AC_MSG_ERROR([sasl/sasl.h not found])])
-AC_CHECK_LIB(sasl2, sasl_client_init, [SASL_LIBS="-lsasl2"])
-AC_SUBST(SASL_LIBS)
+PKG_CHECK_MODULES([SASL], [libsasl2])
dnl ---------------------------------------------------------------------------
dnl - Check for CURL