summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bcd4edc..1423a9e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,6 +42,12 @@ PLYMOUTH_LIBS="-lm -ldl $IMAGE_LIBS"
AC_SUBST(PLYMOUTH_CFLAGS)
AC_SUBST(PLYMOUTH_LIBS)
+AC_ARG_ENABLE(tracing, AS_HELP_STRING([--enable-tracing],[enable verbose tracing code]),enable_tracing=$enableval,enable_tracing=yes)
+
+if test x$enable_tracing = xyes; then
+ AC_DEFINE(PLY_ENABLE_TRACING, 1, [Build in verbose debug tracing spew])
+fi
+
AC_OUTPUT([Makefile
src/libply/Makefile
src/splash-plugins/Makefile