summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRay Strode <rstrode@redhat.com>2008-05-20 23:02:51 -0400
committerRay Strode <rstrode@redhat.com>2008-05-20 23:02:51 -0400
commitb738dda91500cbea6133cd245f7f17e44a5a134f (patch)
tree3320820ee439fddd4f4c1aeea7bf7bfa6648ba30 /configure.ac
parentc9ce1429835279b48f6a9f6e2566ec17609432c7 (diff)
downloadplymouth-b738dda91500cbea6133cd245f7f17e44a5a134f.tar.gz
plymouth-b738dda91500cbea6133cd245f7f17e44a5a134f.tar.xz
plymouth-b738dda91500cbea6133cd245f7f17e44a5a134f.zip
Build in tracing by default and toggle on with ctrl-v
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bcd4edc..1423a9e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,6 +42,12 @@ PLYMOUTH_LIBS="-lm -ldl $IMAGE_LIBS"
AC_SUBST(PLYMOUTH_CFLAGS)
AC_SUBST(PLYMOUTH_LIBS)
+AC_ARG_ENABLE(tracing, AS_HELP_STRING([--enable-tracing],[enable verbose tracing code]),enable_tracing=$enableval,enable_tracing=yes)
+
+if test x$enable_tracing = xyes; then
+ AC_DEFINE(PLY_ENABLE_TRACING, 1, [Build in verbose debug tracing spew])
+fi
+
AC_OUTPUT([Makefile
src/libply/Makefile
src/splash-plugins/Makefile