summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 75e8ffbd..5d74aa18 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -910,6 +910,11 @@ ns_slapd_CPPFLAGS = $(AM_CPPFLAGS) @sasl_inc@ @ldapsdk_inc@ @nss_inc@ \
@nspr_inc@ @svrcore_inc@
ns_slapd_LDADD = libslapd.la libldaputil.a $(LDAPSDK_LINK) $(NSS_LINK) \
$(NSPR_LINK) $(SASL_LINK) $(SVRCORE_LINK) $(LIBNSL) $(LIBSOCKET)
+# We need to link ns-slapd with the C++ compiler on HP-UX since we load
+# some C++ shared libraries (such as icu).
+if HPUX
+ns_slapd_LINK = $(CXXLINK)
+endif
#------------------------
# pwdhash