summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNathan Kinder <nkinder@redhat.com>2007-02-21 17:44:13 +0000
committerNathan Kinder <nkinder@redhat.com>2007-02-21 17:44:13 +0000
commitfa05437fb16b35caa6337c0d216466a374436a47 (patch)
tree0666c68c7ba869fd7cbb16fdbd92e95ade89ca47 /Makefile.am
parent6ea6bd03b9d95fdc3f34a6892eb9d7bff580324f (diff)
downloadds-fa05437fb16b35caa6337c0d216466a374436a47.tar.gz
ds-fa05437fb16b35caa6337c0d216466a374436a47.tar.xz
ds-fa05437fb16b35caa6337c0d216466a374436a47.zip
Resolves: 229428
Summary: ns-slapd needs to be linked with the C++ compiler on HP-UX.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 75e8ffbd..5d74aa18 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -910,6 +910,11 @@ ns_slapd_CPPFLAGS = $(AM_CPPFLAGS) @sasl_inc@ @ldapsdk_inc@ @nss_inc@ \
@nspr_inc@ @svrcore_inc@
ns_slapd_LDADD = libslapd.la libldaputil.a $(LDAPSDK_LINK) $(NSS_LINK) \
$(NSPR_LINK) $(SASL_LINK) $(SVRCORE_LINK) $(LIBNSL) $(LIBSOCKET)
+# We need to link ns-slapd with the C++ compiler on HP-UX since we load
+# some C++ shared libraries (such as icu).
+if HPUX
+ns_slapd_LINK = $(CXXLINK)
+endif
#------------------------
# pwdhash