summaryrefslogtreecommitdiffstats
path: root/ocaml/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ocaml/Makefile.am')
-rw-r--r--ocaml/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/ocaml/Makefile.am b/ocaml/Makefile.am
index 8daa6717..28c13c5f 100644
--- a/ocaml/Makefile.am
+++ b/ocaml/Makefile.am
@@ -135,7 +135,10 @@ depend: .depend
.depend: $(wildcard *.mli) $(wildcard *.ml)
rm -f $@ $@-t
- $(OCAMLFIND) ocamldep $^ | sed 's/ *$$//' | sort > $@-t
+ $(OCAMLFIND) ocamldep $^ | \
+ $(SED) 's/ *$$//' | \
+ $(SED) -e :a -e '/ *\\$$/N; s/ *\\\n */ /; ta' | \
+ sort > $@-t
mv $@-t $@
include .depend