summaryrefslogtreecommitdiffstats
path: root/ocaml/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2011-09-12 11:33:19 +0100
committerRichard Jones <rjones@redhat.com>2011-09-12 11:33:19 +0100
commitcbef2ffb0432756822cd2b02a305384f814e9b50 (patch)
tree615222384dfb8ef082bb52ed309b378e14a7b4e6 /ocaml/Makefile.am
parentb3f1457fddd19b1e540866fa01c665aeb371cb44 (diff)
downloadlibguestfs-cbef2ffb0432756822cd2b02a305384f814e9b50.tar.gz
libguestfs-cbef2ffb0432756822cd2b02a305384f814e9b50.tar.xz
libguestfs-cbef2ffb0432756822cd2b02a305384f814e9b50.zip
Stable OCaml dependencies.
Diffstat (limited to 'ocaml/Makefile.am')
-rw-r--r--ocaml/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/ocaml/Makefile.am b/ocaml/Makefile.am
index 8daa6717..28c13c5f 100644
--- a/ocaml/Makefile.am
+++ b/ocaml/Makefile.am
@@ -135,7 +135,10 @@ depend: .depend
.depend: $(wildcard *.mli) $(wildcard *.ml)
rm -f $@ $@-t
- $(OCAMLFIND) ocamldep $^ | sed 's/ *$$//' | sort > $@-t
+ $(OCAMLFIND) ocamldep $^ | \
+ $(SED) 's/ *$$//' | \
+ $(SED) -e :a -e '/ *\\$$/N; s/ *\\\n */ /; ta' | \
+ sort > $@-t
mv $@-t $@
include .depend