summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2011-08-05 14:03:18 +0100
committerRichard W.M. Jones <rjones@redhat.com>2011-08-05 14:03:18 +0100
commit75cc0fc72c190353dd36f1badf6b142ee4bec079 (patch)
tree3b62791bd385069b5603d3a317409cf904e00e43 /src/Makefile.am
parentf45b40029d1e21e3b426218dd3c4123d8d0d1c70 (diff)
downloadlibguestfs-75cc0fc72c190353dd36f1badf6b142ee4bec079.tar.gz
libguestfs-75cc0fc72c190353dd36f1badf6b142ee4bec079.tar.xz
libguestfs-75cc0fc72c190353dd36f1badf6b142ee4bec079.zip
gnulib: Add all other libs when linking libguestfs.so.
This updates the previous two commits.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f63ae37b..fa088fea 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -144,8 +144,15 @@ libguestfs_la_SOURCES = \
libguestfs_la_LIBADD = \
$(HIVEX_LIBS) $(AUGEAS_LIBS) $(PCRE_LIBS) $(MAGIC_LIBS) \
$(LIBVIRT_LIBS) $(LIBXML2_LIBS) \
- $(LTLIBTHREAD) $(LIB_CLOCK_GETTIME) \
- ../gnulib/lib/libgnu.la
+ ../gnulib/lib/libgnu.la \
+ $(GETADDRINFO_LIB) \
+ $(HOSTENT_LIB) \
+ $(INET_NTOP_LIB) \
+ $(LIBSOCKET) \
+ $(LIB_CLOCK_GETTIME) \
+ $(LIBINTL) \
+ $(LTLIBTHREAD) \
+ $(SERVENT_LIB)
# Make libguestfs include the convenience libraries.
noinst_LTLIBRARIES = liberrnostring.la libprotocol.la