summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2011-08-05 13:52:42 +0100
committerRichard W.M. Jones <rjones@redhat.com>2011-08-05 13:52:42 +0100
commitf45b40029d1e21e3b426218dd3c4123d8d0d1c70 (patch)
tree69871c530ba92712cb5c3c5884acd4c7644fd276 /src/Makefile.am
parent60d5a50f4d3d9e2c2f5a7d42a6859de709bda3f6 (diff)
downloadlibguestfs-f45b40029d1e21e3b426218dd3c4123d8d0d1c70.tar.gz
libguestfs-f45b40029d1e21e3b426218dd3c4123d8d0d1c70.tar.xz
libguestfs-f45b40029d1e21e3b426218dd3c4123d8d0d1c70.zip
gnulib: Add $(LIB_CLOCK_GETTIME) when linking libguestfs.so.
We don't use this library (it is only used in the daemon), but we need to add this to make the linker happy.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6c0cc33d..f63ae37b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -144,7 +144,8 @@ libguestfs_la_SOURCES = \
libguestfs_la_LIBADD = \
$(HIVEX_LIBS) $(AUGEAS_LIBS) $(PCRE_LIBS) $(MAGIC_LIBS) \
$(LIBVIRT_LIBS) $(LIBXML2_LIBS) \
- $(LTLIBTHREAD) ../gnulib/lib/libgnu.la
+ $(LTLIBTHREAD) $(LIB_CLOCK_GETTIME) \
+ ../gnulib/lib/libgnu.la
# Make libguestfs include the convenience libraries.
noinst_LTLIBRARIES = liberrnostring.la libprotocol.la