summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2012-04-30 11:33:19 +0100
committerRichard W.M. Jones <rjones@redhat.com>2012-05-01 09:39:35 +0100
commit027fefd517b8a93c54611a6cc4c51a54fea1b9fe (patch)
tree143c33d12478dd2f66a60d3d28c3529806b5bec7 /Makefile.am
parent75514ab57a06e534f26698fe1725ca29b966c3ad (diff)
downloadlibguestfs-027fefd517b8a93c54611a6cc4c51a54fea1b9fe.tar.gz
libguestfs-027fefd517b8a93c54611a6cc4c51a54fea1b9fe.tar.xz
libguestfs-027fefd517b8a93c54611a6cc4c51a54fea1b9fe.zip
Add gettext support for OCaml tools (virt-resize, virt-sparsify, virt-sysprep).
Note that this support is optional: To enable it, install the ocaml-gettext library from http://forge.ocamlcore.org/projects/ocaml-gettext . If this library is not installed, then configure detects this and inserts dummy gettext functions that do nothing.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index fe37b821..97d76ed1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -211,8 +211,9 @@ dist-hook:
mv AUTHORS-t AUTHORS
cp AUTHORS $(distdir)/AUTHORS
-# Update the list of translatable files (po/POTFILES). This has to be
-# in the top-level Makefile.am so that we have access to DIST_SUBDIRS.
+# Update the list of translatable files (po/POTFILES po/POTFILES-ml).
+# This has to be in the top-level Makefile.am so that we have access
+# to DIST_SUBDIRS.
all-local:
cd $(srcdir); \
find $(DIST_SUBDIRS) \
@@ -230,6 +231,9 @@ all-local:
grep -v '^images/' | \
LC_ALL=C sort | \
sed 's,^\./,,' > po/POTFILES
+ cd $(srcdir); \
+ find resize sparsify sysprep -name '*.ml' | \
+ LC_ALL=C sort > po/POTFILES-ml
# Make clean.