summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeng Wu <alexepico@gmail.com>2016-11-29 15:54:21 +0800
committerPeng Wu <alexepico@gmail.com>2016-11-29 15:55:23 +0800
commite71cc7443ff93e00bb34ce01bbd3440531b542ed (patch)
tree92bfb22b48d6ec620f46e179b401bac126f366ab /CMakeLists.txt
parent01a316ede141e931b871e066c9b87f5af3a3368f (diff)
downloadlibpinyin-e71cc7443ff93e00bb34ce01bbd3440531b542ed.tar.gz
libpinyin-e71cc7443ff93e00bb34ce01bbd3440531b542ed.tar.xz
libpinyin-e71cc7443ff93e00bb34ce01bbd3440531b542ed.zip
update cmake files
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 9 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d681ddf..feff90f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -74,13 +74,15 @@ if (DB_FOUND)
SET (HAVE_BERKELEY_DB 1)
endif (DB_FOUND)
-# DBM: Kyoto Cabinet
-find_package(KyotoCabinet)
-if (KyotoCabinet_FOUND)
- include_directories ( ${KyotoCabinet_INCLUDE_PATH} )
- SET (LIBS ${LIBS} ${KyotoCabinet_LIBRARY})
- SET (HAVE_KYOTO_CABINET 1)
-endif (KyotoCabinet_FOUND)
+if (NOT HAVE_BERKELEY_DB)
+ # DBM: Kyoto Cabinet
+ find_package(KyotoCabinet)
+ if (KyotoCabinet_FOUND)
+ include_directories ( ${KyotoCabinet_INCLUDE_PATH} )
+ SET (LIBS ${LIBS} ${KyotoCabinet_LIBRARY})
+ SET (HAVE_KYOTO_CABINET 1)
+ endif (KyotoCabinet_FOUND)
+endif (NOT HAVE_BERKELEY_DB)
######## Windows