summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 9 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d681ddf..feff90f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -74,13 +74,15 @@ if (DB_FOUND)
SET (HAVE_BERKELEY_DB 1)
endif (DB_FOUND)
-# DBM: Kyoto Cabinet
-find_package(KyotoCabinet)
-if (KyotoCabinet_FOUND)
- include_directories ( ${KyotoCabinet_INCLUDE_PATH} )
- SET (LIBS ${LIBS} ${KyotoCabinet_LIBRARY})
- SET (HAVE_KYOTO_CABINET 1)
-endif (KyotoCabinet_FOUND)
+if (NOT HAVE_BERKELEY_DB)
+ # DBM: Kyoto Cabinet
+ find_package(KyotoCabinet)
+ if (KyotoCabinet_FOUND)
+ include_directories ( ${KyotoCabinet_INCLUDE_PATH} )
+ SET (LIBS ${LIBS} ${KyotoCabinet_LIBRARY})
+ SET (HAVE_KYOTO_CABINET 1)
+ endif (KyotoCabinet_FOUND)
+endif (NOT HAVE_BERKELEY_DB)
######## Windows