summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c344762..94da686 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -46,6 +46,11 @@ DISTCLEANFILES = \
po/stamp-it \
$(NULL)
+dist-hook:
+ if test -d .git ; then \
+ git log --name-status --date=iso > $(distdir)/ChangeLog ; \
+ fi
+
rpm: dist @PACKAGE_NAME@.spec
rpmbuild -bb \
--define "_sourcedir `pwd`" \