summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPeng Huang <shawn.p.huang@gmail.com>2010-04-17 19:39:58 +0800
committerPeng Huang <shawn.p.huang@gmail.com>2010-04-17 19:39:58 +0800
commit2bb3f4dda26efcdcd93fcae0b2e5983a324272aa (patch)
tree83b946b1f16fc66e18016012e031615011143cd9 /Makefile.am
parent414466300e91073a3af1f8c43024f8aeb454954d (diff)
downloadibus-libpinyin-2bb3f4dda26efcdcd93fcae0b2e5983a324272aa.tar.gz
ibus-libpinyin-2bb3f4dda26efcdcd93fcae0b2e5983a324272aa.tar.xz
ibus-libpinyin-2bb3f4dda26efcdcd93fcae0b2e5983a324272aa.zip
Generate ChangeLog from git during make dist
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c344762..94da686 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -46,6 +46,11 @@ DISTCLEANFILES = \
po/stamp-it \
$(NULL)
+dist-hook:
+ if test -d .git ; then \
+ git log --name-status --date=iso > $(distdir)/ChangeLog ; \
+ fi
+
rpm: dist @PACKAGE_NAME@.spec
rpmbuild -bb \
--define "_sourcedir `pwd`" \