summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPavel Raiskup <praiskup@redhat.com>2015-03-02 09:41:33 +0100
committerPavel Raiskup <praiskup@redhat.com>2015-03-02 10:10:53 +0100
commit7b1dbe74c98f5be41ad5605260f0edbf40a9fcd1 (patch)
tree12ce1599858a23ee9a0d9088543450b9e4617f62 /Makefile.am
parent9094981751e776fa93537c91bc0e678f4d806b91 (diff)
downloadpostgresql-setup-7b1dbe74c98f5be41ad5605260f0edbf40a9fcd1.tar.gz
postgresql-setup-7b1dbe74c98f5be41ad5605260f0edbf40a9fcd1.tar.xz
postgresql-setup-7b1dbe74c98f5be41ad5605260f0edbf40a9fcd1.zip
postgresql-check-db-dir: match configuration approach
* configure.ac (PGDATADIR): Use /var/lib/pgsql/data when prefix is set to /usr. (rawpkgdatadir): New directory. Its different from pkgdatadir, because thats often set to /usr/share/postgresql. * Makefile.am: Include new rawpkgdatadir Makefile.inc. Fix distcheck by mentioning legacyscripts_SCRIPTS in GENERATED_FILES. * postgresql-check-db-dir.in: Use library.sh to give user better advice. Use @NAME_BINARYBASE@ prefix. (bad_version): New function. (PREVMAJORVERSION): Removed unused variable. * postgresql-setup.in: Cut out the config-parsing routines into library.sh. * share/postgresql-setup/library.sh.in: New library file. Added new option 'list' for parse_upgrade_setup. * share/postgresql-setup/Makefile.inc: New file. * share/postgresql-setup/.gitignore: Ignore library.sh.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 21d448a..6371bb7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -78,6 +78,8 @@ EXTRA_DIST += \
$(srcdir)/*.in \
$(srcdir)/etc/postgresql-setup/upgrade/postgresql.conf
+include $(srcdir)/share/postgresql-setup/Makefile.inc
+
GENERATED_FILES += \
$(bin_SCRIPTS) \
$(libexec_SCRIPTS) \
@@ -85,7 +87,7 @@ GENERATED_FILES += \
$(pkgsysconf_DATA) \
$(systemdunits_DATA) \
$(initscripts_DATA) \
- $(systemdlegacyscripts_SCRIPTS)
+ $(legacyscripts_SCRIPTS)
CLEANFILES += $(GENERATED_FILES) $(TEST_GEN_FILES_LIST)