summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPavel Raiskup <praiskup@redhat.com>2015-02-27 15:57:08 +0100
committerPavel Raiskup <praiskup@redhat.com>2015-02-27 16:08:11 +0100
commit9094981751e776fa93537c91bc0e678f4d806b91 (patch)
treef8fae32b51dbd08ef2343da8084d6dbab9d0f6f3 /Makefile.am
parent28c5dbbab21fb19606cb548582885458928eda30 (diff)
downloadpostgresql-setup-9094981751e776fa93537c91bc0e678f4d806b91.tar.gz
postgresql-setup-9094981751e776fa93537c91bc0e678f4d806b91.tar.xz
postgresql-setup-9094981751e776fa93537c91bc0e678f4d806b91.zip
configury: another scl-izing commit
* Makefile.am: Move systemd directory definitions into configure.ac. This is then easily configurable via config.site. * configure.ac (PGENGINE, PG_CTL_BIN): Remove, bindir is sufficient. (PREVMAJORVERSION, PREVPGENGINE): Removed. It si configurable now. (INIDB_SCLS): Generalize into SCLS variable. (SCLS): Moved from INIDB_SCLS. (PGDATADIR): Default changed to have ${prefix} inside. (SED_RULES): Remove unused variables (or to not be used, TODO for next commit). (conf_dir): New macro to define config.site friendly directory variable. (SCL_SHELL_WRAPPER): Convenient macro to generate appropriate call to scl binary (only when building for software collections). * postgresql-check-db-dir.in: Use new variable layout. * postgresql-ctl.in: Likewise. * postgresql-setup.in: Likewise. * postgresql.service.in: Likewise. This fixes regression of not using ${bindir} properly.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 2 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index b575702..21d448a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -28,17 +28,14 @@ SUBDIRS = . doc tests
bin_SCRIPTS = $(setup)
libexec_SCRIPTS = $(ctl) $(checkdb)
-userunitsdir = /etc/systemd/system
+legacyscriptsdir = $(systemdlegacyscriptsdir)/$(NAME_SERVICE)
# TODO: Ideally, 'make distcheck' should check every file we generate.
if WANT_SYSVINIT
-initscriptsdir = $(sysconfdir)/rc.d/init.d
initscripts_DATA = $(initscript)
else
-systemdunitsdir = $(prefix)/lib/systemd/system
systemdunits_DATA = $(service) $(serviceat)
-systemdlegacyscriptsdir = $(libexecdir)/initscripts/legacy-actions/$(NAME_SERVICE)
-systemdlegacyscripts_SCRIPTS = initdb upgrade
+legacyscripts_SCRIPTS = initdb upgrade
endif
doc_DATA = $(README_DIST_BASENAME)