summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPavel Raiskup <praiskup@redhat.com>2014-07-01 12:05:55 +0200
committerPavel Raiskup <praiskup@redhat.com>2014-07-01 12:05:55 +0200
commit4a30b44a89dc107912cd2613137bceca63895047 (patch)
tree6d79fcdca6c1d0b58da8461733798bdf82402e30 /Makefile.am
parent8c49d3b08882c0c5a6bd546fd5bf0a14e68b3357 (diff)
downloadpostgresql-setup-4a30b44a89dc107912cd2613137bceca63895047.tar.gz
postgresql-setup-4a30b44a89dc107912cd2613137bceca63895047.tar.xz
postgresql-setup-4a30b44a89dc107912cd2613137bceca63895047.zip
generate also README.rpm-dist
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b4c3a37..43ab15a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -10,6 +10,8 @@ pkgsysconf_DATA = conf/postgresql$(DISTSUFF)
systemdunitsdir = $(prefix)/lib/systemd/system
systemdunits_DATA = postgresql$(DISTSUFF).service
+nodist_pgdoc_DATA = README.rpm-dist
+
config_status = $(top_srcdir)/config.status
postgresql$(DISTSUFF)-ctl: postgresql-ctl.in
@@ -28,4 +30,11 @@ postgresql$(DISTSUFF).service: postgresql.service.in
$(AM_V_GEN)cmd="$(config_status) --file=$@:$<" ; \
if $(AM_V_P); then $$cmd; else $$cmd &>/dev/null; fi
-CLEANFILES = $(bin_SCRIPTS) $(libexec_SCRIPTS)
+README.rpm-dist: README.rpm-dist.in
+ $(AM_V_GEN)cmd="$(config_status) --file=$@:$<" ; \
+ if $(AM_V_P); then $$cmd; else $$cmd &>/dev/null; fi
+
+CLEANFILES = $(bin_SCRIPTS) \
+ $(libexec_SCRIPTS) \
+ $(nodist_pgdoc_DATA) \
+ $(nodist_systemdunits_DATA)