summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPavel Raiskup <praiskup@redhat.com>2014-07-01 11:01:03 +0200
committerPavel Raiskup <praiskup@redhat.com>2014-07-01 11:01:03 +0200
commit8c49d3b08882c0c5a6bd546fd5bf0a14e68b3357 (patch)
tree845c5837566dafec8d5945f09115bc278175e856 /Makefile.am
parent00683dad1a27a49e99f4a28e3924e1c97b1b9594 (diff)
downloadpostgresql-setup-8c49d3b08882c0c5a6bd546fd5bf0a14e68b3357.tar.gz
postgresql-setup-8c49d3b08882c0c5a6bd546fd5bf0a14e68b3357.tar.xz
postgresql-setup-8c49d3b08882c0c5a6bd546fd5bf0a14e68b3357.zip
Generate postgresql.service and configuration file
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d981ecc..b4c3a37 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,6 +4,12 @@ bin_SCRIPTS = postgresql$(DISTSUFF)-setup
libexec_SCRIPTS = postgresql$(DISTSUFF)-ctl
+pkgsysconfdir = $(PKGCONFIG_DIR)
+pkgsysconf_DATA = conf/postgresql$(DISTSUFF)
+
+systemdunitsdir = $(prefix)/lib/systemd/system
+systemdunits_DATA = postgresql$(DISTSUFF).service
+
config_status = $(top_srcdir)/config.status
postgresql$(DISTSUFF)-ctl: postgresql-ctl.in
@@ -14,4 +20,12 @@ postgresql$(DISTSUFF)-setup: postgresql-setup.in
$(AM_V_GEN)cmd="$(config_status) --file=$@:$<" ; \
if $(AM_V_P); then $$cmd; else $$cmd &>/dev/null; fi && chmod +x $@
+conf/postgresql$(DISTSUFF): conf/postgresql.in
+ $(AM_V_GEN)cmd="$(config_status) --file=$@:$<" ; \
+ if $(AM_V_P); then $$cmd; else $$cmd &>/dev/null; fi
+
+postgresql$(DISTSUFF).service: postgresql.service.in
+ $(AM_V_GEN)cmd="$(config_status) --file=$@:$<" ; \
+ if $(AM_V_P); then $$cmd; else $$cmd &>/dev/null; fi
+
CLEANFILES = $(bin_SCRIPTS) $(libexec_SCRIPTS)