summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorFabiano Fidêncio <fidencio@redhat.com>2017-02-12 22:20:26 +0100
committerLukas Slebodnik <lslebodn@redhat.com>2017-03-02 16:46:23 +0100
commit9c0c83eecf963416effee67dab55711234373fde (patch)
tree579524f7aecd13fc9d2d8969e3931192a42b9968 /Makefile.am
parent54039570d26e29444c398aa4ad6ba638f1713566 (diff)
downloadsssd-9c0c83eecf963416effee67dab55711234373fde.tar.gz
sssd-9c0c83eecf963416effee67dab55711234373fde.tar.xz
sssd-9c0c83eecf963416effee67dab55711234373fde.zip
SYSTEMD: Don't mix up responders' socket and monitor activation
Let's ensure that in case a responder is explicitly configured in the sssd.conf its socket won't even start. The patchset introduces a new binary that will be distributed and will be called before starting the responders' sockets, ensuring the sockets will only start in case the responder is supposed to be socket-activated and its been configured accordingly. Otherwise the responders' socket startup will fail with a quite helpful debug message leading the admins to choose between using systemd or not and what has to be done to achieve their desire. This suggestion came from Sumit Bose. The reason for adding a new binary instead of a simple python script is to avoid dragging unnecessary dependencies to sssd-common package. Resolves: https://pagure.io/SSSD/sssd/issue/3300 Signed-off-by: Fabiano Fidêncio <fidencio@redhat.com> Reviewed-by: Jakub Hrozek <jhrozek@redhat.com> Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 182a84e3a..34da1f002 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -190,6 +190,9 @@ endif
if BUILD_PAC_RESPONDER
sssdlibexec_PROGRAMS += sssd_pac
endif
+if HAVE_SYSTEMD_UNIT
+sssdlibexec_PROGRAMS += sssd_check_socket_activated_responders
+endif
if HAVE_CHECK
non_interactive_check_based_tests = \
@@ -1688,6 +1691,22 @@ sss_ssh_knownhostsproxy_LDADD = \
$(CLIENT_LIBS) $(TALLOC_LIBS) $(POPT_LIBS)
endif
+if HAVE_SYSTEMD_UNIT
+sssd_check_socket_activated_responders_SOURCES = \
+ src/tools/sssd_check_socket_activated_responders.c \
+ $(NULL)
+sssd_check_socket_activated_responders_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(NULL)
+sssd_check_socket_activated_responders_LDADD = \
+ $(SSSD_INTERNAL_LTLIBS) \
+ $(LTLIBINTL) \
+ $(TALLOC_LIBS) \
+ $(POPT_LIBS) \
+ $(INI_CONFIG_LIBS) \
+ $(NULL)
+endif
+
#################
# Feature Tests #
#################