summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2017-02-22 14:34:06 +0100
committerLukas Slebodnik <lslebodn@redhat.com>2017-03-02 12:48:37 +0100
commit54039570d26e29444c398aa4ad6ba638f1713566 (patch)
treedcf6fa586fe284bed0c4dc435e838791fbd1c9e8 /Makefile.am
parent6dd271fdcf6ceb0afd77e703c98897672da3671a (diff)
downloadsssd-54039570d26e29444c398aa4ad6ba638f1713566.tar.gz
sssd-54039570d26e29444c398aa4ad6ba638f1713566.tar.xz
sssd-54039570d26e29444c398aa4ad6ba638f1713566.zip
cache_req: use own namespace for UPNs
If the UPN use the same domain name as the configured domain an unsuccessful lookup by name will already create an entry in the negative cache. If the lookup by UPN would use the same namespace the lookup will immediately be finished because there would already be an entry in the negative cache. Resolves: https://pagure.io/SSSD/sssd/issue/3313 Reviewed-by: Pavel Březina <pbrezina@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 30ee5e590..182a84e3a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2192,6 +2192,7 @@ nss_srv_tests_CFLAGS = \
$(AM_CFLAGS)
nss_srv_tests_LDFLAGS = \
-Wl,-wrap,sss_ncache_check_user \
+ -Wl,-wrap,sss_ncache_check_upn \
-Wl,-wrap,sss_ncache_check_uid \
-Wl,-wrap,sss_ncache_check_sid \
-Wl,-wrap,sss_ncache_check_cert \