summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorFabiano Fidêncio <fidencio@redhat.com>2017-03-24 23:15:04 +0100
committerJakub Hrozek <jhrozek@redhat.com>2017-03-29 14:00:17 +0200
commit723d514f641e2b5a5cbfe1c6c7bdd2a6f3c5070e (patch)
tree29fb37ddaf1993f874cd10e4995d6e38378ba082 /Makefile.am
parent2e85b015d8dd231094a09eab69b86e8b6fcc8b2b (diff)
downloadsssd-723d514f641e2b5a5cbfe1c6c7bdd2a6f3c5070e.tar.gz
sssd-723d514f641e2b5a5cbfe1c6c7bdd2a6f3c5070e.tar.xz
sssd-723d514f641e2b5a5cbfe1c6c7bdd2a6f3c5070e.zip
SYSDB/TESTS: Add tests for the domain's resolution order methods
Introduce a new and small set of tests for these new helper methods that are going to be used in different parts of the code in the follow-up patches. Related: https://pagure.io/SSSD/sssd/issue/3001 Signed-off-by: Fabiano Fidêncio <fidencio@redhat.com> Reviewed-by: Sumit Bose <sbose@redhat.com> Reviewed-by: Pavel Březina <pbrezina@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8052150be..450785bf4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -263,6 +263,7 @@ if HAVE_CMOCKA
test_sysdb_certmap \
test_sysdb_sudo \
test_sysdb_utils \
+ test_sysdb_domain_resolution_order \
test_wbc_calls \
test_be_ptask \
test_copy_ccache \
@@ -2875,6 +2876,21 @@ test_sysdb_utils_LDADD = \
libsss_test_common.la \
$(NULL)
+test_sysdb_domain_resolution_order_SOURCES = \
+ src/tests/cmocka/test_sysdb_domain_resolution_order.c \
+ $(NULL)
+test_sysdb_domain_resolution_order_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(NULL)
+test_sysdb_domain_resolution_order_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(LDB_LIBS) \
+ $(POPT_LIBS) \
+ $(TALLOC_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_test_common.la \
+ $(NULL)
+
test_wbc_calls_SOURCES = \
src/tests/cmocka/test_wbc_calls.c \
src/sss_client/idmap/sss_nss_idmap.c \