summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorFabiano Fidêncio <fidencio@redhat.com>2017-03-24 15:29:23 +0100
committerJakub Hrozek <jhrozek@redhat.com>2017-03-29 14:00:17 +0200
commit2e85b015d8dd231094a09eab69b86e8b6fcc8b2b (patch)
tree456db7c019ef724896c9131fea4901bc5067999c /Makefile.am
parent5856a621ac5909ca96520ac5a809eb83fd46d8bc (diff)
downloadsssd-2e85b015d8dd231094a09eab69b86e8b6fcc8b2b.tar.gz
sssd-2e85b015d8dd231094a09eab69b86e8b6fcc8b2b.tar.xz
sssd-2e85b015d8dd231094a09eab69b86e8b6fcc8b2b.zip
SYSDB: Add methods to deal with the domain's resolution order
In the following-up patches those newly introduced methods will be used to deal with the domainResolutionOrder attribute. The sysdb_update_domain_resolution_order() method is purposely not checking whether a value has changed or not before writing to sysdb and while may not be optimal, the readability of the code has increased a lot by keeping it as simple as possible. Tests for these new methods are part of the next commit. Related: https://pagure.io/SSSD/sssd/issue/3001 Signed-off-by: Fabiano Fidêncio <fidencio@redhat.com> Reviewed-by: Sumit Bose <sbose@redhat.com> Reviewed-by: Pavel Březina <pbrezina@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 359feddef..8052150be 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -736,6 +736,7 @@ dist_noinst_HEADERS = \
src/db/sysdb_private.h \
src/db/sysdb_services.h \
src/db/sysdb_ssh.h \
+ src/db/sysdb_domain_resolution_order.h \
src/confdb/confdb.h \
src/confdb/confdb_private.h \
src/confdb/confdb_setup.h \
@@ -995,6 +996,7 @@ libsss_util_la_SOURCES = \
src/db/sysdb_idmap.c \
src/db/sysdb_gpo.c \
src/db/sysdb_certmap.c \
+ src/db/sysdb_domain_resolution_order.c \
src/monitor/monitor_sbus.c \
src/providers/dp_auth_util.c \
src/providers/dp_pam_data_util.c \