summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRobin Hack <rhack@redhat.com>2013-09-19 08:11:59 +0200
committerRobin Hack <rhack@redhat.com>2013-09-19 08:11:59 +0200
commit0f356df6cc42573ed7bf91ffb4ba8da4f516f5b4 (patch)
tree95ab5a36aa155dae53d9e57def4d3bdb5b07f450 /CMakeLists.txt
parent432ca8bc789b2d41353726dd87f4f656c7499627 (diff)
downloadopenlmi-providers-0f356df6cc42573ed7bf91ffb4ba8da4f516f5b4.tar.gz
openlmi-providers-0f356df6cc42573ed7bf91ffb4ba8da4f516f5b4.tar.xz
openlmi-providers-0f356df6cc42573ed7bf91ffb4ba8da4f516f5b4.zip
Providers: Switch to -fstack-protector-strong.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 447be1f..1f62c37 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,7 +10,7 @@ cmake_minimum_required(VERSION 2.6)
# Set flags and definitions
add_definitions(-D_XOPEN_SOURCE=500 -D_GNU_SOURCE)
-set(CMAKE_C_FLAGS "-std=c99 -fstack-protector -Wall -pedantic -g -Wextra -Wno-unused-parameter -Wformat -Wparentheses -Wl,--no-undefined ${CMAKE_C_FLAGS}")
+set(CMAKE_C_FLAGS "-std=c99 -fstack-protector-strong -Wall -pedantic -g -Wextra -Wno-unused-parameter -Wformat -Wparentheses -Wl,--no-undefined ${CMAKE_C_FLAGS}")
# Set LIB_SUFFIX to 64 on 64bit architectures
if(CMAKE_SIZEOF_VOID_P EQUAL 4)