summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRobin Hack <rhack@redhat.com>2013-09-19 07:50:55 +0200
committerRobin Hack <rhack@redhat.com>2013-09-19 07:50:55 +0200
commit432ca8bc789b2d41353726dd87f4f656c7499627 (patch)
treee446d780086ed387d52aab3589eb8c5d148fe1ca /CMakeLists.txt
parentcd13c983a49ce3685a3813e66001bd3ea8f796c8 (diff)
downloadopenlmi-providers-432ca8bc789b2d41353726dd87f4f656c7499627.tar.gz
openlmi-providers-432ca8bc789b2d41353726dd87f4f656c7499627.tar.xz
openlmi-providers-432ca8bc789b2d41353726dd87f4f656c7499627.zip
Providers: Added -fstack-protector gcc flag.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d3184e9..447be1f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,7 +10,7 @@ cmake_minimum_required(VERSION 2.6)
# Set flags and definitions
add_definitions(-D_XOPEN_SOURCE=500 -D_GNU_SOURCE)
-set(CMAKE_C_FLAGS "-std=c99 -Wall -pedantic -g -Wextra -Wno-unused-parameter -Wformat -Wparentheses -Wl,--no-undefined ${CMAKE_C_FLAGS}")
+set(CMAKE_C_FLAGS "-std=c99 -fstack-protector -Wall -pedantic -g -Wextra -Wno-unused-parameter -Wformat -Wparentheses -Wl,--no-undefined ${CMAKE_C_FLAGS}")
# Set LIB_SUFFIX to 64 on 64bit architectures
if(CMAKE_SIZEOF_VOID_P EQUAL 4)