summaryrefslogtreecommitdiffstats
path: root/runtime/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-04-16 11:36:22 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2008-04-16 11:36:22 +0200
commit75f3cb34e6ce1c8c782e5c612765dc39b76cc3df (patch)
tree16f7ef0b88b8e102a36169f5082818cc505051ed /runtime/Makefile.am
parent8f8f65abb66d1a7839c30c2d1b4b4d653a8990cc (diff)
downloadrsyslog-75f3cb34e6ce1c8c782e5c612765dc39b76cc3df.tar.gz
rsyslog-75f3cb34e6ce1c8c782e5c612765dc39b76cc3df.tar.xz
rsyslog-75f3cb34e6ce1c8c782e5c612765dc39b76cc3df.zip
moved net module to runtime
after careful analysis, I concluded that it is OK to place the current net.c/.h code under LGPL. Individual contributor agreement is given and no sysklogd code remains (see net.c for details).
Diffstat (limited to 'runtime/Makefile.am')
-rw-r--r--runtime/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/runtime/Makefile.am b/runtime/Makefile.am
index 048ef411..8cb3a638 100644
--- a/runtime/Makefile.am
+++ b/runtime/Makefile.am
@@ -75,3 +75,14 @@ lmregexp_la_LDFLAGS = -module -avoid-version $(rsrt_libs)
lmregexp_la_LIBADD =
endif
+if ENABLE_INET
+pkglib_LTLIBRARIES += lmnet.la
+#
+# network support
+#
+lmnet_la_SOURCES = net.c net.h
+lmnet_la_CPPFLAGS = $(pthreads_cflags) $(rsrt_cflags)
+lmnet_la_LDFLAGS = -module -avoid-version $(rsrt_libs)
+lmnet_la_LIBADD =
+
+endif # if ENABLE_INET