summaryrefslogtreecommitdiffstats
path: root/runtime/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-04-16 10:26:54 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2008-04-16 10:26:54 +0200
commit8f8f65abb66d1a7839c30c2d1b4b4d653a8990cc (patch)
tree8bd92ca19ae3cccd5b160c717960db88bb095e73 /runtime/Makefile.am
parent3af28bbd2dc4c79b242aad3b9e3f45cffe0f19d0 (diff)
downloadrsyslog-8f8f65abb66d1a7839c30c2d1b4b4d653a8990cc.tar.gz
rsyslog-8f8f65abb66d1a7839c30c2d1b4b4d653a8990cc.tar.xz
rsyslog-8f8f65abb66d1a7839c30c2d1b4b4d653a8990cc.zip
moved files to the runtime
there are still some files left which could go into the runtime, but I think we will delete most of them once we are done with the full modularization.
Diffstat (limited to 'runtime/Makefile.am')
-rw-r--r--runtime/Makefile.am32
1 files changed, 29 insertions, 3 deletions
diff --git a/runtime/Makefile.am b/runtime/Makefile.am
index cd8a19c2..048ef411 100644
--- a/runtime/Makefile.am
+++ b/runtime/Makefile.am
@@ -1,9 +1,36 @@
sbin_PROGRAMS =
man_MANS =
noinst_LTLIBRARIES = librsyslog.la
+pkglib_LTLIBRARIES =
#pkglib_LTLIBRARIES = librsyslog.la
librsyslog_la_SOURCES = \
+ rsyslog.h \
+ atomic.h \
+ syslogd-types.h \
+ module-template.h \
+ obj-types.h \
+ glbl.h \
+ msg.c \
+ msg.h \
+ linkedlist.c \
+ linkedlist.h \
+ objomsr.c \
+ objomsr.h \
+ stringbuf.c \
+ stringbuf.h \
+ datetime.c \
+ datetime.h \
+ srutils.c \
+ srUtils.h \
+ errmsg.c \
+ errmsg.h \
+ debug.c \
+ debug.h \
+ obj.c \
+ obj.h \
+ modules.c \
+ modules.h \
sync.c \
sync.h \
expr.c \
@@ -33,7 +60,7 @@ librsyslog_la_SOURCES = \
queue.c \
queue.h
-librsyslog_la_CPPFLAGS = -I$(top_srcdir) $(pthreads_cflags)
+librsyslog_la_CPPFLAGS = -D_PATH_MODDIR=\"$(pkglibdir)/\" -I$(top_srcdir) $(pthreads_cflags)
#librsyslog_la_LDFLAGS = -module -avoid-version
librsyslog_la_LIBADD =
@@ -41,8 +68,7 @@ librsyslog_la_LIBADD =
# regular expression support
#
if ENABLE_REGEXP
-noinst_LTLIBRARIES += lmregexp.la
-#pkglib_LTLIBRARIES += lmregexp.la
+pkglib_LTLIBRARIES += lmregexp.la
lmregexp_la_SOURCES = regexp.c regexp.h
lmregexp_la_CPPFLAGS = $(pthreads_cflags) $(rsrt_cflags)
lmregexp_la_LDFLAGS = -module -avoid-version $(rsrt_libs)