summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2015-06-04 10:51:05 +0200
committerJakub Hrozek <jhrozek@redhat.com>2015-06-14 21:47:20 +0200
commit64ea4127f463798410a2c20e0261c6b15f60257f (patch)
tree35591187021deb529f91fb069b3cca7fb225ea71 /Makefile.am
parentf4025ea817b3467be1c2e6092014a11fe4547c0d (diff)
downloadsssd-64ea4127f463798410a2c20e0261c6b15f60257f.tar.gz
sssd-64ea4127f463798410a2c20e0261c6b15f60257f.tar.xz
sssd-64ea4127f463798410a2c20e0261c6b15f60257f.zip
IPA: Fetch keytab for 1way trusts
Uses the ipa-getkeytab call to retrieve keytabs for one-way trust relationships. https://fedorahosted.org/sssd/ticket/2636 Reviewed-by: Sumit Bose <sbose@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4eed1069b..ae44549ac 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2455,15 +2455,18 @@ test_ipa_subdom_server_SOURCES = \
test_ipa_subdom_server_CFLAGS = \
$(AM_CFLAGS) \
-DUNIT_TESTING \
+ -DIPA_TRUST_KEYTAB_DIR=TEST_DIR \
$(NULL)
test_ipa_subdom_server_LDFLAGS = \
-Wl,-wrap,krb5_kt_default \
+ -Wl,-wrap,execle \
$(NULL)
test_ipa_subdom_server_LDADD = \
$(PAM_LIBS) \
$(CMOCKA_LIBS) \
$(SSSD_LIBS) \
$(CARES_LIBS) \
+ $(KEYUTILS_LIBS) \
$(KRB5_LIBS) \
$(SSSD_INTERNAL_LTLIBS) \
libsss_ldap_common.la \
@@ -3283,6 +3286,7 @@ src/sysv/systemd/journal.conf: src/sysv/systemd/journal.conf.in Makefile
SSSD_USER_DIRS = \
$(DESTDIR)$(dbpath) \
+ $(DESTDIR)$(dbpath)/keytabs \
$(DESTDIR)$(mcpath) \
$(DESTDIR)$(pipepath) \
$(DESTDIR)$(pipepath)/private \