summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 8bf0c4e3..1c908f94 100644
--- a/configure.in
+++ b/configure.in
@@ -1275,7 +1275,12 @@ if test -n "$pkg_systemdsystemunitdir"; then
fi
if test -z "$systemdsystemunitdir"; then
- systemdsystemunitdir='/lib/systemd/system';
+ systemdsystemunitdir='${exec_prefix}/lib/systemd/system';
+fi
+
+systemdutildir=$($PKG_CONFIG --variable=systemdutildir systemd)
+if test -z "$systemdutildir"; then
+ systemdutildir='${exec_prefix}/lib/systemd';
fi
################################################################################
AC_ARG_WITH(tmpfilesdir,
@@ -1549,6 +1554,7 @@ AC_SUBST(tmpdir)
AC_SUBST(udev_prefix)
AC_SUBST(udevdir)
AC_SUBST(systemdsystemunitdir)
+AC_SUBST(systemdutildir)
AC_SUBST(tmpfilesdir)
AC_SUBST(usrlibdir)
AC_SUBST(usrsbindir)