summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorPeter Rajnoha <prajnoha@redhat.com>2012-07-31 16:46:24 +0200
committerPeter Rajnoha <prajnoha@redhat.com>2012-07-31 16:46:24 +0200
commitfa68466e904568d054f0b0cf5fdab6499cb47998 (patch)
treedbbf29f7353a509c30f57601f197c5caa9fd0719 /configure.in
parentd3e67ba8ca13115ffdd324e64e965240dced8ef1 (diff)
downloadlvm2-fa68466e904568d054f0b0cf5fdab6499cb47998.tar.gz
lvm2-fa68466e904568d054f0b0cf5fdab6499cb47998.tar.xz
lvm2-fa68466e904568d054f0b0cf5fdab6499cb47998.zip
systemd: integrate lvm2 activation generator with conf+make
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 8bf0c4e3..1c908f94 100644
--- a/configure.in
+++ b/configure.in
@@ -1275,7 +1275,12 @@ if test -n "$pkg_systemdsystemunitdir"; then
fi
if test -z "$systemdsystemunitdir"; then
- systemdsystemunitdir='/lib/systemd/system';
+ systemdsystemunitdir='${exec_prefix}/lib/systemd/system';
+fi
+
+systemdutildir=$($PKG_CONFIG --variable=systemdutildir systemd)
+if test -z "$systemdutildir"; then
+ systemdutildir='${exec_prefix}/lib/systemd';
fi
################################################################################
AC_ARG_WITH(tmpfilesdir,
@@ -1549,6 +1554,7 @@ AC_SUBST(tmpdir)
AC_SUBST(udev_prefix)
AC_SUBST(udevdir)
AC_SUBST(systemdsystemunitdir)
+AC_SUBST(systemdutildir)
AC_SUBST(tmpfilesdir)
AC_SUBST(usrlibdir)
AC_SUBST(usrsbindir)