summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/configure.in b/src/configure.in
index 3101439fdb..67ccac2a2b 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -1015,12 +1015,15 @@ int i = 1;
fi
if test "$k5_cv_openssl_version_okay" = yes && (test "$enable_pkinit" = yes || test "$enable_pkinit" = try); then
K5_GEN_MAKEFILE(plugins/preauth/pkinit)
+ PKINIT=yes
elif test "$k5_cv_openssl_version_okay" = no && test "$enable_pkinit" = yes; then
AC_MSG_ERROR([Version of OpenSSL is too old; cannot enable PKINIT.])
else
AC_DEFINE([DISABLE_PKINIT], 1, [Define to disable PKINIT plugin support])
AC_MSG_NOTICE([Disabling PKINIT support.])
+ PKINIT=no
fi
+AC_SUBST(PKINIT)
# for lib/apputils
AC_REPLACE_FUNCS(daemon)