summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorGreg Hudson <ghudson@mit.edu>2012-01-06 20:52:02 +0000
committerGreg Hudson <ghudson@mit.edu>2012-01-06 20:52:02 +0000
commit138db9ebba7d0d2f69ce47584f0f1d33d7eeb348 (patch)
tree6c5692046c6c3434fdd50cf9f9374ec2770467ab /src/configure.in
parente0e94b5f8d392be83be3f55cf83141126d27fd01 (diff)
downloadkrb5-138db9ebba7d0d2f69ce47584f0f1d33d7eeb348.tar.gz
krb5-138db9ebba7d0d2f69ce47584f0f1d33d7eeb348.tar.xz
krb5-138db9ebba7d0d2f69ce47584f0f1d33d7eeb348.zip
Add test cases for PKINIT ASN.1 encoders
Do not add decode tests, because those would trip some bugs in the decoders, and we can't safely fix some of those bugs without interop testing. Encode tests are sufficient to detect when we unintentionally change the output of the encoders. Fix trval2() not to use the context shortcut on primitive context tags. git-svn-id: svn://anonsvn.mit.edu/krb5/trunk@25609 dc483132-0cff-0310-8789-dd5450dbe970
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/configure.in b/src/configure.in
index 3101439fdb..67ccac2a2b 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -1015,12 +1015,15 @@ int i = 1;
fi
if test "$k5_cv_openssl_version_okay" = yes && (test "$enable_pkinit" = yes || test "$enable_pkinit" = try); then
K5_GEN_MAKEFILE(plugins/preauth/pkinit)
+ PKINIT=yes
elif test "$k5_cv_openssl_version_okay" = no && test "$enable_pkinit" = yes; then
AC_MSG_ERROR([Version of OpenSSL is too old; cannot enable PKINIT.])
else
AC_DEFINE([DISABLE_PKINIT], 1, [Define to disable PKINIT plugin support])
AC_MSG_NOTICE([Disabling PKINIT support.])
+ PKINIT=no
fi
+AC_SUBST(PKINIT)
# for lib/apputils
AC_REPLACE_FUNCS(daemon)