summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index c8e7429..291bdb2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -38,16 +38,14 @@ AC_PROG_CC
AM_PROG_CC_C_O
AC_PROG_LIBTOOL
+AC_CHECK_PROGS(ICOTOOL, [icotool], [icotool])
+
AS_IF([test "x$os_win32" = "xyes"], [
AC_CHECK_TOOL(WINDRES, [windres])
- AC_CHECK_PROGS(ICOTOOL, [icotool])
if test -z "$WINDRES" ; then
AC_MSG_ERROR("windres is required to compile virt-viewer on this platform")
fi
- if test -z "$ICOTOOL" ; then
- AC_MSG_ERROR("icotool is required to compile virt-viewer on this platform")
- fi
])
AC_CONFIG_LIBOBJ_DIR([src])