summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@gmail.com>2012-05-14 19:07:35 +0200
committerMarc-André Lureau <marcandre.lureau@gmail.com>2012-05-14 23:27:20 +0200
commit8e1a8b32421aaf4c8f0e5dd1f75b456e631f339f (patch)
tree42fcf17a63a9864e12138d803f6b201ee404c08b /configure.ac
parent88893e30bc49833749464bfff4c369cb50bf7fb9 (diff)
downloadvirt-viewer-8e1a8b32421aaf4c8f0e5dd1f75b456e631f339f.tar.gz
virt-viewer-8e1a8b32421aaf4c8f0e5dd1f75b456e631f339f.tar.xz
virt-viewer-8e1a8b32421aaf4c8f0e5dd1f75b456e631f339f.zip
dist: ship .ico in tarball
Some distros (a 4-letters) don't have icotool. Let's ship the .ico in the tarball. The build will fail if icoutil is not installed when building from git or when the .ico is absent. The error should be explicit.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index c8e7429..291bdb2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -38,16 +38,14 @@ AC_PROG_CC
AM_PROG_CC_C_O
AC_PROG_LIBTOOL
+AC_CHECK_PROGS(ICOTOOL, [icotool], [icotool])
+
AS_IF([test "x$os_win32" = "xyes"], [
AC_CHECK_TOOL(WINDRES, [windres])
- AC_CHECK_PROGS(ICOTOOL, [icotool])
if test -z "$WINDRES" ; then
AC_MSG_ERROR("windres is required to compile virt-viewer on this platform")
fi
- if test -z "$ICOTOOL" ; then
- AC_MSG_ERROR("icotool is required to compile virt-viewer on this platform")
- fi
])
AC_CONFIG_LIBOBJ_DIR([src])