summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2015-07-06 18:17:11 +0200
committerChristophe Fergeau <cfergeau@redhat.com>2015-08-07 11:54:46 +0200
commiteb2e8ba0e8055a90f1425cacdb2c55660a087a6a (patch)
tree65ff03dfde545f6000cd6acdb40b21454dba5604 /Makefile.am
parent26eb4e0f2edf6e6183ef8bd9a35564d72260e5e0 (diff)
downloadspice-protocol-eb2e8ba0e8055a90f1425cacdb2c55660a087a6a.tar.gz
spice-protocol-eb2e8ba0e8055a90f1425cacdb2c55660a087a6a.tar.xz
spice-protocol-eb2e8ba0e8055a90f1425cacdb2c55660a087a6a.zip
build-sys: Make sure new files are dist'ed
The just added .proto files and python code generation code need to be added to EXTRA_DIST in order to be distributed in tarballs, and we need to recurse in the new python_modules directory.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d2e49a4..e509dd6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,14 @@
NULL =
-SUBDIRS = spice
+SUBDIRS = python_modules spice
+
+codegendir = $(libdir)/spice-protocol
+dist_codegen_DATA = \
+ spice_codegen.py \
+ spice.proto \
+ spice1.proto \
+ $(NULL)
+
+DISTCLEANFILES = *.pyc
pkgconfigdir = $(datadir)/pkgconfig
pkgconfig_DATA = spice-protocol.pc