summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2015-02-07 02:01:34 +0100
committerMarc-André Lureau <marcandre.lureau@redhat.com>2015-03-03 14:50:03 +0100
commit85ed26847ce631bb21b89bee90d250979b8178bd (patch)
tree328ff22a359d7462f1ef6778d9031391f4c9df63 /configure.ac
parent4e9c936dc245f8dd08417bd46aef826bad66ed6f (diff)
downloadspice-gtk-85ed26847ce631bb21b89bee90d250979b8178bd.tar.gz
spice-gtk-85ed26847ce631bb21b89bee90d250979b8178bd.tar.xz
spice-gtk-85ed26847ce631bb21b89bee90d250979b8178bd.zip
Use libphodav-2 (breaks webdav server temporarily)
This change breaks webdav server, since libphodav-2 no longer set up a TCP service running in a thread. It's up to the client to decide how best to accept and handle new connections. This commits remove all the hacks related to proxying the incoming connections to a TCP socket, and protected with a magic sequence. The following commit will use GIOStream pipes to handle each client connections.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d98e502..263f38b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -278,7 +278,7 @@ AC_ARG_ENABLE([webdav],
if test "x$enable_webdav" = "xno"; then
have_phodav="no"
else
- PKG_CHECK_MODULES(PHODAV, [libphodav-1.0 glib-2.0 >= 2.43.90], [have_phodav=yes], [have_phodav=no])
+ PKG_CHECK_MODULES(PHODAV, [libphodav-2.0 glib-2.0 >= 2.43.90 libsoup-2.4 >= 2.49.1], [have_phodav=yes], [have_phodav=no])
AC_SUBST(PHODAV_CFLAGS)
AC_SUBST(PHODAV_LIBS)