summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2015-02-12 04:09:33 +0100
committerMarc-André Lureau <marcandre.lureau@redhat.com>2015-03-03 14:11:58 +0100
commit4e9c936dc245f8dd08417bd46aef826bad66ed6f (patch)
tree4a65bd25584b8022deac500dfa5a2d60219898bc /configure.ac
parentca59cb30c1af0d89efa21570237b8adbe965e8b4 (diff)
downloadspice-gtk-4e9c936dc245f8dd08417bd46aef826bad66ed6f.tar.gz
spice-gtk-4e9c936dc245f8dd08417bd46aef826bad66ed6f.tar.xz
spice-gtk-4e9c936dc245f8dd08417bd46aef826bad66ed6f.zip
Add GIOStream-based pipe
This code creates a pipe between 2 GIOStream, the input side read from the peer output side, and vice-versa. In the following patches, this will avoid the socket communication to exchange with the embedded webdav server. glib-2.0 >= 2.43.90 because GSimpleIOStream dependency.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4e88dec..d98e502 100644
--- a/configure.ac
+++ b/configure.ac
@@ -278,7 +278,7 @@ AC_ARG_ENABLE([webdav],
if test "x$enable_webdav" = "xno"; then
have_phodav="no"
else
- PKG_CHECK_MODULES(PHODAV, [libphodav-1.0], [have_phodav=yes], [have_phodav=no])
+ PKG_CHECK_MODULES(PHODAV, [libphodav-1.0 glib-2.0 >= 2.43.90], [have_phodav=yes], [have_phodav=no])
AC_SUBST(PHODAV_CFLAGS)
AC_SUBST(PHODAV_LIBS)
@@ -289,6 +289,8 @@ fi
AS_IF([test "x$have_phodav" = "xyes"],
AC_DEFINE([USE_PHODAV], [1], [Define if supporting phodav]))
+AM_CONDITIONAL([WITH_PHODAV], [test "x$have_phodav" = "xyes"])
+
AC_ARG_WITH([audio],
AS_HELP_STRING([--with-audio=@<:@gstreamer/pulse/auto/no@:>@], [Select audio backend @<:@default=auto@:>@]),
[],