summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2014-10-29 21:16:23 +0100
committerChristophe Fergeau <cfergeau@redhat.com>2014-10-31 18:06:10 +0100
commit1e7bb3c8f72fa327a4e455356f624154b9d5cc74 (patch)
treec4061c16c5119750e7f2f1f8f6cd31d5cee1ce09 /configure.ac
parentd4d60c9742390ea12db29e116f22b340efc5a67c (diff)
downloadspice-gtk-1e7bb3c8f72fa327a4e455356f624154b9d5cc74.tar.gz
spice-gtk-1e7bb3c8f72fa327a4e455356f624154b9d5cc74.tar.xz
spice-gtk-1e7bb3c8f72fa327a4e455356f624154b9d5cc74.zip
Drop glib < 2.28 support
With el6 now shipping glib 2.28, there is no very good reason to keep support for older glib versions alive, especially as it will barely be tested.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 3 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 71830e2..613a128 100644
--- a/configure.ac
+++ b/configure.ac
@@ -244,7 +244,7 @@ fi
AC_CHECK_FUNCS(clearenv strtok_r)
-PKG_CHECK_MODULES(GLIB2, glib-2.0 >= 2.22)
+PKG_CHECK_MODULES(GLIB2, glib-2.0 >= 2.28)
AC_SUBST(GLIB2_CFLAGS)
AC_SUBST(GLIB2_LIBS)
@@ -256,9 +256,6 @@ PKG_CHECK_MODULES(GIO, gio-2.0 >= 2.10.0 $gio_os)
AC_SUBST(GIO_CFLAGS)
AC_SUBST(GIO_LIBS)
-PKG_CHECK_EXISTS([gio-2.0 >= 2.26], [have_gio26=yes])
-AM_CONDITIONAL([WITH_GPROXY], [test "x$have_gio26" = "xyes"])
-
PKG_CHECK_MODULES(CAIRO, cairo >= 1.2.0)
AC_SUBST(CAIRO_CFLAGS)
AC_SUBST(CAIRO_LIBS)
@@ -690,15 +687,8 @@ AC_ARG_ENABLE([dbus],
have_dbus=no
if test "x$enable_dbus" != "xno"; then
- if test "x$have_gio26" = "xyes"; then
- AC_DEFINE([USE_GDBUS], [1], [Define if supporting gdbus])
- have_dbus=gdbus
- else
- PKG_CHECK_EXISTS([DBUS_GLIB], [dbus-glib-1], [
- AC_DEFINE([USE_DBUS_GLIB], [1], [Define if supporting dbus-glib])
- have_dbus=dbus-glib
- ])
- fi
+ AC_DEFINE([USE_GDBUS], [1], [Define if supporting gdbus])
+ have_dbus=yes
if test "x$enable_dbus" = "xyes" && test "x$have_dbus" = "xno"; then
AC_MSG_ERROR([D-Bus support explicitly requested, but some required packages are not available])