summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVictor Toso <vtosodec@redhat.com>2012-10-09 12:10:23 +0200
committerVictor Toso <vtosodec@redhat.com>2014-10-31 14:59:29 +0100
commitd4d60c9742390ea12db29e116f22b340efc5a67c (patch)
treeaadb7c5ff84f8a7c7c4e3298b3e2119fca38164c /configure.ac
parenta577a155c19f50dd1ffaa7d30275a6fab17f6100 (diff)
downloadspice-gtk-d4d60c9742390ea12db29e116f22b340efc5a67c.tar.gz
spice-gtk-d4d60c9742390ea12db29e116f22b340efc5a67c.tar.xz
spice-gtk-d4d60c9742390ea12db29e116f22b340efc5a67c.zip
Add GStreamer 1.0 audio support
Based on Christophe Fergeau's patch. To enable audio with GStreamer 1.0: --with-audio=gstreamer1 There is only a few changes between those versions, worth mentioning: - audio capabilities "audio/x-raw,format=..." instead of "audio/x-raw-int,..." - appsink signal for new data changed from "new-buffer" to "new-sample"
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 14 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index ce36d93..71830e2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -288,7 +288,7 @@ AS_IF([test "x$have_phodav" = "xyes"],
AC_DEFINE([USE_PHODAV], [1], [Define if supporting phodav]))
AC_ARG_WITH([audio],
- AS_HELP_STRING([--with-audio=@<:@gstreamer/pulse/auto/no@:>@], [Select audio backend @<:@default=auto@:>@]),
+ AS_HELP_STRING([--with-audio=@<:@gstreamer/gstreamer1/pulse/auto/no@:>@], [Select audio backend @<:@default=auto@:>@]),
[],
[with_audio="auto"])
@@ -297,7 +297,7 @@ AS_IF([test "x$with_audio" = "xauto"], [
])
case "$with_audio" in
- gstreamer|pulse|no*)
+ gstreamer|gstreamer1|pulse|no*)
;;
*) AC_MSG_ERROR(Unsupported audio backend)
esac
@@ -326,7 +326,18 @@ AS_IF([test "x$have_gst" = "xyes"],
[AC_MSG_ERROR([GStreamer requested but not found])
])
])
-AM_CONDITIONAL([WITH_GSTAUDIO], [test "x$have_gst" = "xyes"])
+
+AS_IF([test "x$with_audio" = "xgstreamer1"],
+ [PKG_CHECK_MODULES(GST, gstreamer-1.0 gstreamer-base-1.0 gstreamer-app-1.0 gstreamer-audio-1.0, [have_gst1=yes], [have_gst1=no])],
+ [have_gst1=no])
+
+AS_IF([test "x$have_gst1" = "xyes"],
+ [AC_DEFINE([WITH_GST1AUDIO], 1, [Have GStreamer 1.0?])],
+ [AS_IF([test "x$with_audio" = "xgstreamer1"],
+ [AC_MSG_ERROR([GStreamer 1.0 requested but not found])
+ ])
+])
+AM_CONDITIONAL([WITH_GSTAUDIO], [test "x$have_gst" = "xyes" -o "x$have_gst1" = "xyes"])
AC_SUBST(GST_CFLAGS)
AC_SUBST(GST_LIBS)