summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2015-10-09 15:07:27 +0200
committerChristophe Fergeau <cfergeau@redhat.com>2015-10-13 11:26:01 +0200
commitf7ec855af3deff18aeb43ddbf2467c565f4bf346 (patch)
treec1073296a6309d5342744b1c5865c15717d2aa4c /configure.ac
parent26a533d6ebeca0679674d94cb384a3da8ad0afa0 (diff)
downloadspice-common-f7ec855af3deff18aeb43ddbf2467c565f4bf346.tar.gz
spice-common-f7ec855af3deff18aeb43ddbf2467c565f4bf346.tar.xz
spice-common-f7ec855af3deff18aeb43ddbf2467c565f4bf346.zip
build-sys: Rework SPICE_CHECK_* m4 macros
These macros were automatically appending the needed CFLAGS/LIBS to variables passed as arguments. This is how spice-common uses them, but now how spice-gtk/spice want to use them, and is making the macros more complicated than they could (in particular this makes them use AS_VAR_APPEND). This is also not flexible enough as spice-gtk uses libcacard libraries, while spice-common does not need them. If SPICE_CHECK_SMARTCARD unconditionnally libcacard libraries to the variable spice-common passes it as an argument, we'll end up linking with an unneeded library. This commit removes this automatic appending from the SPICE_CHECK_* macros and moves it to spice-common as it's the only one which needs it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 9 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index ad775bc..fde03e7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,12 +34,15 @@ AC_SUBST([CODE_GENERATOR_BASEDIR])
SPICE_CHECK_PYTHON_MODULES()
-SPICE_CHECK_PIXMAN(SPICE_COMMON)
-SPICE_CHECK_SMARTCARD(SPICE_COMMON)
-SPICE_CHECK_CELT051(SPICE_COMMON)
-SPICE_CHECK_GLIB2(SPICE_COMMON)
-SPICE_CHECK_OPUS(SPICE_COMMON)
-SPICE_CHECK_OPENGL(SPICE_COMMON)
+SPICE_CHECK_PIXMAN
+SPICE_CHECK_SMARTCARD
+SPICE_CHECK_CELT051
+SPICE_CHECK_GLIB2
+SPICE_CHECK_OPUS
+SPICE_CHECK_OPENGL
+
+SPICE_COMMON_CFLAGS='$(PIXMAN_CFLAGS) $(SMARTCARD_CFLAGS) $(CELT051_CFLAGS) $(GLIB2_CFLAGS) $(OPUS_CFLAGS) $(GL_CFLAGS)'
+SPICE_COMMON_LIBS='$(PIXMAN_LIBS) $(CELT051_LIBS) $(GLIB2_LIBS) $(OPUS_LIBS) $(GL_LIBS)'
AC_SUBST(SPICE_COMMON_CFLAGS)
AC_SUBST(SPICE_COMMON_LIBS)