summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2015-10-07 15:48:29 +0200
committerChristophe Fergeau <cfergeau@redhat.com>2015-10-07 18:01:17 +0200
commit26a533d6ebeca0679674d94cb384a3da8ad0afa0 (patch)
tree714cc805992be34a319fd6abd3617e24c6159526 /configure.ac
parent523875d8c5691bc07f4b50d89106f4f489400f0e (diff)
downloadspice-common-26a533d6ebeca0679674d94cb384a3da8ad0afa0.tar.gz
spice-common-26a533d6ebeca0679674d94cb384a3da8ad0afa0.tar.xz
spice-common-26a533d6ebeca0679674d94cb384a3da8ad0afa0.zip
build-sys: Use ${PKG_CONFIG} rather than pkg-config
In mingw builds, this will be set to mingw-pkg-config rather than the host system one. This is fixing a build failure on mingw when spice-protocol is only installed in the mingw prefix and not system-wide.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3468bbf..ad775bc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -29,7 +29,7 @@ SPICE_CHECK_SYSDEPS
# Checks for libraries
PKG_CHECK_MODULES([PROTOCOL], [spice-protocol >= 0.12.10])
-CODE_GENERATOR_BASEDIR=`pkg-config --variable=codegendir spice-protocol`
+CODE_GENERATOR_BASEDIR=`${PKG_CONFIG} --variable=codegendir spice-protocol`
AC_SUBST([CODE_GENERATOR_BASEDIR])
SPICE_CHECK_PYTHON_MODULES()