summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 042de1ee..d47de5b4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -275,6 +275,7 @@ case $host in
# assume 64 bit
perlexec='/opt/perl_64/bin/perl'
platform="hpux"
+ initconfigdir="/$PACKAGE_NAME/config"
;;
hppa*-hp-hpux*)
AC_DEFINE([XP_UNIX], [1], [UNIX])
@@ -287,6 +288,7 @@ case $host in
AC_DEFINE([_POSIX_C_SOURCE], [199506L], [POSIX revision])
AC_DEFINE([_HPUX_SOURCE], [1], [Source namespace])
# assume 64 bit
+ initconfigdir="/$PACKAGE_NAME/config"
perlexec='/opt/perl_64/bin/perl'
platform="hpux"
;;
@@ -327,6 +329,19 @@ esac
AC_SUBST(initdir)
AC_SUBST(perlexec)
+# set default initconfigdir if not already set
+# value will be set so as to be relative to $(sysconfdir)
+if test -z "$initconfigdir" ; then
+ if test -d /etc/sysconfig ; then
+ initconfigdir=/sysconfig
+ elif test -d /etc/default ; then
+ initconfigdir=/default
+ else
+ initconfigdir="/$PACKAGE_NAME/config"
+ fi
+fi
+AC_SUBST(initconfigdir)
+
AM_CONDITIONAL(HPUX,test "$platform" = "hpux")
AM_CONDITIONAL(SOLARIS,test "$platform" = "solaris")