summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRich Megginson <rmeggins@redhat.com>2007-10-05 23:45:50 +0000
committerRich Megginson <rmeggins@redhat.com>2007-10-05 23:45:50 +0000
commitb786eb2121dc924b985966036095f3f9ca638cf6 (patch)
tree1747652ad5f4da7e8c8a6e46850dc193840d66ca /configure.ac
parentb47079a1c1f3e29762925554f7bfaf9f22dedddd (diff)
downloadds-b786eb2121dc924b985966036095f3f9ca638cf6.tar.gz
ds-b786eb2121dc924b985966036095f3f9ca638cf6.tar.xz
ds-b786eb2121dc924b985966036095f3f9ca638cf6.zip
Resolves: bug 248169
Bug Description: init script modification needed for kerberos auth Reviewed by: nhosoi (Thanks!) Fix Description: I just took Simo's initial patch and ran with it. The initconfigdir parameter is the directory containing the config file for the init script. configure will first try to use $(sysconfdir)/sysconfig, then $(sysconfdir)/default (Solaris and Debian, among others), then the package config directory (the default on HP-UX), for this parameter. The init script and startup script will look in the initconfigdir to find the init config file to source. For directory server, an instance specific file can be used, named e.g. dirsrv-localhost which will apply to the slapd-localhost instance only. A default init config file is provided for dirsrv and dirsrv-admin, with some examples of how it could be used. Platforms tested: RHEL5 x86_64 Flag Day: Yes - autotool file changes Doc impact: Yes. We will need to document how the user can supply environment to the servers at startup time without having to edit the init scripts or the startup scripts. QA impact: should be covered by regular nightly and manual testing New Tests integrated into TET: none
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 042de1ee..d47de5b4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -275,6 +275,7 @@ case $host in
# assume 64 bit
perlexec='/opt/perl_64/bin/perl'
platform="hpux"
+ initconfigdir="/$PACKAGE_NAME/config"
;;
hppa*-hp-hpux*)
AC_DEFINE([XP_UNIX], [1], [UNIX])
@@ -287,6 +288,7 @@ case $host in
AC_DEFINE([_POSIX_C_SOURCE], [199506L], [POSIX revision])
AC_DEFINE([_HPUX_SOURCE], [1], [Source namespace])
# assume 64 bit
+ initconfigdir="/$PACKAGE_NAME/config"
perlexec='/opt/perl_64/bin/perl'
platform="hpux"
;;
@@ -327,6 +329,19 @@ esac
AC_SUBST(initdir)
AC_SUBST(perlexec)
+# set default initconfigdir if not already set
+# value will be set so as to be relative to $(sysconfdir)
+if test -z "$initconfigdir" ; then
+ if test -d /etc/sysconfig ; then
+ initconfigdir=/sysconfig
+ elif test -d /etc/default ; then
+ initconfigdir=/default
+ else
+ initconfigdir="/$PACKAGE_NAME/config"
+ fi
+fi
+AC_SUBST(initconfigdir)
+
AM_CONDITIONAL(HPUX,test "$platform" = "hpux")
AM_CONDITIONAL(SOLARIS,test "$platform" = "solaris")